const regex = /([A-Z][a-z]+)([A-Z].*)\s.*/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([A-Z][a-z]+)([A-Z].*)\\s.*', '')
const str = `WonderWorld NEW`;
const subst = `$1 $2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);