re = /([A-Z][a-z]+)([A-Z].*)\s.*/
str = 'WonderWorld NEW'
subst = '$1 $2'
result = str.sub(re, subst)
# Print the result of the substitution
puts result