using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=href="")^(?!\/(get|PICSNUM))[a-z0-9-_\/.]+";
string input = @"<a href=""/video5505298733/travel_and_tourism_recovery_coronavirus."" title=""The places and companies missing tourist dollars most."">The places and companies missing tourist dollars most.</a></p><p class=""info""><span class=""bg""><span class=""duration"">10 min</span><a href=""/get/index.php?id=qafMsaaScGLPuKqGuanBpZjHtGHKppeHpJu5r6G9raaHoqa3tJS-ope5tJK6s5TLqp8""><span class=""name"">CORONAVIRUS</span></a><span><span class=""bolder""> - </span> 1.7k <span class=""bolder"">Views</span></span><span class=""text-disabled""><span class=""bolder""> - </span> 2 days ago</span><span class=""bolder""> - </span></span></p></div></div> <div class=""thumb-lock ""><div class=""thumb-big""><div class=""thumb""><a href=""/midia54891337/PICSNUM/russia_fire_coronavirus_patients_intl""><img src=""lightbox.gif"" data-src=""https://cdn-pic.cnews-cdn.com/videos/thumbs169/22/d3/a2/22d3a23423dfda7f5/22d3a2dfbb9fdfgd43f5.PICNUM.jpg"" /></a>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}