import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=href=\")^(?!\\/(get|PICSNUM))[a-z0-9-_\\/.]+";
final String string = "<a href=\"/video5505298733/travel_and_tourism_recovery_coronavirus.\" title=\"The places and companies missing tourist dollars most.\">The places and companies missing tourist dollars most.</a></p><p class=\"info\"><span class=\"bg\"><span class=\"duration\">10 min</span><a href=\"/get/index.php?id=qafMsaaScGLPuKqGuanBpZjHtGHKppeHpJu5r6G9raaHoqa3tJS-ope5tJK6s5TLqp8\"><span class=\"name\">CORONAVIRUS</span></a><span><span class=\"bolder\"> - </span> 1.7k <span class=\"bolder\">Views</span></span><span class=\"text-disabled\"><span class=\"bolder\"> - </span> 2 days ago</span><span class=\"bolder\"> - </span></span></p></div></div> <div class=\"thumb-lock \"><div class=\"thumb-big\"><div class=\"thumb\"><a href=\"/midia54891337/PICSNUM/russia_fire_coronavirus_patients_intl\"><img src=\"lightbox.gif\" data-src=\"https://cdn-pic.cnews-cdn.com/videos/thumbs169/22/d3/a2/22d3a23423dfda7f5/22d3a2dfbb9fdfgd43f5.PICNUM.jpg\" /></a>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}