re = /^(?![EB]#)[A-G](\#|b)?/m
str = 'A
A#
Ab
B
Bb
C
C#
Cb
D
D#
Db
E
Eb
F
F#
Fb
G
G#
Gb
B#
E#
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end