package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\[.*\]`)
var str = `Bruno[az18sdh].mp4
Franck[juri99].mp4
Serge[8juin].mp4`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}