$re = '/\[.*\]/x';
$str = 'Bruno[az18sdh].mp4
Franck[juri99].mp4
Serge[8juin].mp4';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);