package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[^\\](?:(?:\\{2})*)\$(?:(?:[=|-]?([A-Z0-9_]*[A-Z_]+[A-Z0-9_]*)|(?:{[=|-]?([A-Z0-9_]*[A-Z_]+[A-Z0-9_]*)})))`)
var str = `${HAVE_ERROR}
\\${PATH}
\\$SHELL
\\\\${PATH}
${HTTP_PORT}
$HTTP_PORT
$PORT
$1_PORT
${1_PORT}
$PORT_345
${PORT_345}
${AZK_AGENT_CONF_FILE}
${HTTP_HOST_2345}
${=HTTP_HOST_2345}
${-HTTP_HOST_2345}
$ENV.HTTP
# ^ should match
# v should not match
any_text
LIKE_A_ENV_NAME
\${PATH}
\$SHELL
\ \${PATH}
\ \$SHELL
\\\${PATH}
\\\$SHELL
$1
${1}
$@
$?
${env}
${env.io}
${ENV
${ENV_hahaha}
${ENV.HTTP}
$envs.HTTP_PORT
${envs.HTTP_PORT}
${-net.host}
${-net.port.http}
${=net.port.http}
<%azk.default_domain%>
<%=manifest.dir%>
#{-system.name}
#{=manifest.dir}
#{azk}
#{azk.io}
##hello
$hello
%hello%
<hello>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}