$re = '/(\w+)(\.\w+)+(?!.*(\w+)(\.\w+)+)/';
$str = 'https://my.website.com/reports?ref_=kdp_BS
https://my.website.com/reports.html';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);