$re = '/\. \(([^)]*)\)/m';
$str = '. (some string)';
$subst = ". \n==$1==\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;