re = /\. \(([^)]*)\)/m
str = '. (some string)'
subst = '. \\n==$1==\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result