package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^.*,\d+,[^,]+$`)
var str = `abc,abc,123,123
abc,abc,abc,123
def,feg,345,123`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}