$re = '/^.*,\d+,[^,]+$/m';
$str = 'abc,abc,123,123
abc,abc,abc,123
def,feg,345,123';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);