#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=<)(?:[a-zA-Z]+(?:\+\d+)*)+[a-zA-Z]*(?=>)"
Local $sString = "Matching <abcde> to abcde." & @CRLF & _
"" & @CRLF & _
"<abcde1> should not match anything." & @CRLF & _
"" & @CRLF & _
"Matching <abcde+1> to abcde+1 " & @CRLF & _
"Matching <abcde+1asd+2+3+4as> to abcde+1asd+2+3+4as" & @CRLF & _
"" & @CRLF & _
"<abcde+> should not match anything."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")