import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=<)(?:[a-zA-Z]+(?:\\+\\d+)*)+[a-zA-Z]*(?=>)";
final String string = "Matching <abcde> to abcde.\n\n"
+ "<abcde1> should not match anything.\n\n"
+ "Matching <abcde+1> to abcde+1 \n"
+ "Matching <abcde+1asd+2+3+4as> to abcde+1asd+2+3+4as\n\n"
+ "<abcde+> should not match anything.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}