const regex = new RegExp('(?s)<head\\b[^>]*>(.*?)</head>', '')
const str = `<head>
<meta charset="utf-8">
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<title>PHP: get_meta_tags - Manual </title>
<link rel="canonical" href="http://php.net/manual/en/function.get-
<link rel="contents" href="http://php.net/manual/en/index.php">
<base href="http://php.net/manual/en/function.get-meta-tags.php">
</head>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}