$re = '~(?s)<head\b[^>]*>(.*?)</head>~';
$str = '<head>
<meta charset="utf-8">
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<title>PHP: get_meta_tags - Manual </title>
<link rel="canonical" href="http://php.net/manual/en/function.get-
<link rel="contents" href="http://php.net/manual/en/index.php">
<base href="http://php.net/manual/en/function.get-meta-tags.php">
</head>';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);