package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\bToto[^,]*,`)
var str = `the whole substring from Toto till and including the comma, see here`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}