#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\d(?:\.\d{1,4})?$"
Local $sString = "1" & @CRLF & _
"" & @CRLF & _
"1.2" & @CRLF & _
"" & @CRLF & _
"1.23" & @CRLF & _
"" & @CRLF & _
"1.234" & @CRLF & _
"" & @CRLF & _
"1.2345" & @CRLF & _
"" & @CRLF & _
"These should fail." & @CRLF & _
"" & @CRLF & _
"10" & @CRLF & _
"" & @CRLF & _
"10.1" & @CRLF & _
"" & @CRLF & _
"1.23456"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")