#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?<good>\b(?:\w+\.)*(?:alsogood|good)\.com(?::\w+)?\b)(?: +\g<good>)*$"
Local $sString = "test.good.com:3 great.alsogood.com:latest test2.good.com" & @CRLF & _
"" & @CRLF & _
"foo.bar.good.com:1" & @CRLF & _
"" & @CRLF & _
"I would like it to match the previous strings but not match something like these:" & @CRLF & _
"" & @CRLF & _
"test.good.com:3 another.bad.com great.good.com" & @CRLF & _
"" & @CRLF & _
"foo.bad.com:1"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")