import re
regex = re.compile(r"^(?<good>\b(?:\w+\.)*(?:alsogood|good)\.com(?::\w+)?\b)(?: +\g<good>)*$", flags=re.MULTILINE)
test_str = ("test.good.com:3 great.alsogood.com:latest test2.good.com\n\n"
"foo.bar.good.com:1\n\n"
"I would like it to match the previous strings but not match something like these:\n\n"
"test.good.com:3 another.bad.com great.good.com\n\n"
"foo.bad.com:1")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")