package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).*isaac.*\n.*select`)
var str = `abcdefgisaachijklmnopqrstuvwxyz
abcdefgselecthijklmno
My name is isaac m. newton
let's see if select is on the next line
My name is isaac m. newton, let's see if select is
on the next line
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}