$re = '/.*isaac.*\n.*select/m';
$str = 'abcdefgisaachijklmnopqrstuvwxyz
abcdefgselecthijklmno
My name is isaac m. newton
let\'s see if select is on the next line
My name is isaac m. newton, let\'s see if select is
on the next line
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);