package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:[\-\.\/\s]*[\d↉½⅓⅔¼¾⅕⅖⅗⅘⅙⅚⅐⅛⅜⅝⅞⅑⅒⅟])+`)
var str = `1.5 5 tablespoon cram
½ (1 cup) heavy cream
¼ – ½ teaspoon cream
1 tablespoon cream`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}