re = /^(?:[\-\.\/\s]*[\d↉½⅓⅔¼¾⅕⅖⅗⅘⅙⅚⅐⅛⅜⅝⅞⅑⅒⅟])+/m
str = '1.5 5 tablespoon cram
½ (1 cup) heavy cream
¼ – ½ teaspoon cream
1 tablespoon cream'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end