// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m).*\bwith(.*?),").unwrap();
let string = "This is a test with a string with punctuation, and an end. Then test words, and more text. And here whith more text with more punctuation, like that.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}