$re = '/if\s*\((?P<conditional>(?:(?:(?:"(?:(?:\\\\")|[^"])*")|(?:\'(?:(?:\\\\\')|[^\'])*\'))|[^\(\)]|\((?1)\))*+)\)\s*(?P<true_body>(?:{(?:(?:(?:"(?:(?:\\\\")|[^"])*")|(?:\'(?:(?:\\\\\')|[^\'])*\'))|[^{}]|{(?2)})*+})|(?:[^{}\n]*))\s*(?:(?:else\s+?(?!if)(?P<else_body>(?:{(?:(?:(?:(?:"(?:(?:\\\\")|[^"])*")|(?:\'(?:(?:\\\\\')|[^\'])*\'))|[^{}]|{(?3)})+)})|(?:[^{}\n])*)\s*)|(?:else\s*if\s*\((?P<else_if_condition>(?:(?:(?:"(?:(?:\\\\")|[^"])*")|(?:\'(?:(?:\\\\\')|[^\'])*\'))|[^\(\)]|\((?4)\))+)\)\s*(?P<else_if_body>(?:(?:{(?:(?:(?:"(?:(?:\\\\")|[^"])*")|(?:\'(?:(?:\\\\\')|[^\'])*\'))|[^{}]|{(?5)})+})|(?:[^{}\n]*)))\s*))*/mi';
$str = '// in_out.cpp: определяет точку входа для консольного приложения.
#include "stdafx.h"
#include <iostream>
using namespace std;
int main()
{
int a,
b; // объявление переменных типа int, то есть в таких переменных хранятся только целые числа
cout << "Vvedite
pervoe
chislo: ";
cin >> a;
cout << "Vvedite vtoroe chislo: ";
cin >> b;
if (a > b)
cout << a << " > " << b << endl; // печатать данное сообщение
if (a <
b and c ==k
or (s == f && f==d))
{
cout << a << " < " << b << endl;
cout << a << " < " << b << endl;
cout << a << " < " << b << endl;
cout << a << " < " << b << endl;
cout << a << " < " << b << endl;
cout << a << " < " << b << endl;
if (sdfsdf) {
sdfsdf
}
cout << a << " < " << b << endl;
cout << a << " < " << b << endl;
cout << a << " < " << b << endl;
}
if (a == b) // если а = b
cout << a << " = " << b << endl; // в теле условного оператора опущены фигурные скобочки
system("pause");
return 0;
}
if (a <b) {
cout << a << " < " << b << endl;
}
if (a <b
cvxcv sdfsd sdfsd
sdfds
) {
cout << a << " < " << b << endl;
} else {
dsfsdfsdf
}
if (var1 == "("){
echo "{в";
}
if(boolean_expression 1)
{
// Executes when the boolean expression 1 is true
}
else if(boolean_expression 2)
{
// Executes when the boolean expression 2 is true
}
else if( boolean_expression 3)
{
// Executes when the boolean expression 3 is true
}
else
{
// executes when the none of the above condition is true.
}
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);