# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"if\s*\((?P<conditional>(?:(?:(?:\"(?:(?:\\\")|[^\"])*\")|(?:'(?:(?:\\')|[^'])*'))|[^\(\)]|\((?1)\))*+)\)\s*(?P<true_body>(?:{(?:(?:(?:\"(?:(?:\\\")|[^\"])*\")|(?:'(?:(?:\\')|[^'])*'))|[^{}]|{(?2)})*+})|(?:[^{}\n]*))\s*(?:(?:else\s+?(?!if)(?P<else_body>(?:{(?:(?:(?:(?:\"(?:(?:\\\")|[^\"])*\")|(?:'(?:(?:\\')|[^'])*'))|[^{}]|{(?3)})+)})|(?:[^{}\n])*)\s*)|(?:else\s*if\s*\((?P<else_if_condition>(?:(?:(?:\"(?:(?:\\\")|[^\"])*\")|(?:'(?:(?:\\')|[^'])*'))|[^\(\)]|\((?4)\))+)\)\s*(?P<else_if_body>(?:(?:{(?:(?:(?:\"(?:(?:\\\")|[^\"])*\")|(?:'(?:(?:\\')|[^'])*'))|[^{}]|{(?5)})+})|(?:[^{}\n]*)))\s*))*"
test_str = ("// in_out.cpp: определяет точку входа для консольного приложения.\n"
" \n"
"#include \"stdafx.h\"\n"
"#include <iostream>\n"
"using namespace std;\n"
" \n"
"int main()\n"
"{\n"
" int a, \n\n\n"
"b; // объявление переменных типа int, то есть в таких переменных хранятся только целые числа\n"
" cout << \"Vvedite \n\n"
"pervoe \n\n"
"chislo: \";\n"
" cin >> a;\n"
" cout << \"Vvedite vtoroe chislo: \";\n"
" cin >> b;\n"
" if (a > b) \n"
" cout << a << \" > \" << b << endl; // печатать данное сообщение\n"
" \n"
" if (a <\n"
"b and c ==k\n"
" or (s == f && f==d))\n"
" {\n"
" cout << a << \" < \" << b << endl;\n"
" cout << a << \" < \" << b << endl;\n"
" cout << a << \" < \" << b << endl;\n"
" cout << a << \" < \" << b << endl;\n"
" cout << a << \" < \" << b << endl;\n"
" cout << a << \" < \" << b << endl;\n"
" if (sdfsdf) {\n"
"sdfsdf\n"
" }\n\n"
" cout << a << \" < \" << b << endl;\n"
" cout << a << \" < \" << b << endl;\n\n"
" cout << a << \" < \" << b << endl;\n"
" }\n"
" if (a == b) // если а = b\n"
" cout << a << \" = \" << b << endl; // в теле условного оператора опущены фигурные скобочки\n"
" system(\"pause\");\n"
" return 0;\n"
"}\n\n\n"
" if (a <b) {\n"
" cout << a << \" < \" << b << endl;\n"
" }\n\n\n"
" if (a <b\n"
"cvxcv sdfsd sdfsd \n"
"sdfds \n\n"
") {\n"
" cout << a << \" < \" << b << endl;\n"
" } else {\n"
"dsfsdfsdf\n"
"}\n\n"
"if (var1 == \"(\"){\n"
" echo \"{в\";\n"
"}\n\n\n"
"if(boolean_expression 1)\n"
"{\n"
" // Executes when the boolean expression 1 is true\n"
"}\n"
"else if(boolean_expression 2)\n"
"{\n"
" // Executes when the boolean expression 2 is true\n"
"}\n"
"else if( boolean_expression 3)\n"
"{\n"
" // Executes when the boolean expression 3 is true\n"
"}\n"
"else \n"
"{\n"
" // executes when the none of the above condition is true.\n"
"}\n\n")
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.