import Foundation
let pattern = #"[A-Z][a-z]{3,4} ([0-9]{1,2}), [0-9]{4}"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"Jan 5, 2011"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}