#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?is)site.*?\D\K(\d+\.\d{2})"
Local $sString = "Debit card payment to site.com" & @CRLF & _
"Germany" & @CRLF & _
"on 01 May 1.30" & @CRLF & _
"Debit card payment to site Germany" & @CRLF & _
"on 01 May 4.63" & @CRLF & _
" Debit card payment to site.Com" & @CRLF & _
"Germany" & @CRLF & _
"on 01 May 3.30" & @CRLF & _
"Debit card payment to Paypal *Xiao" & @CRLF & _
"Ref:- 23948 0000000000 32.98" & @CRLF & _
"Debit card payment to site.Com" & @CRLF & _
"Germany" & @CRLF & _
"on 20 May 17.49" & @CRLF & _
"Debit card refund from site.Com" & @CRLF & _
"Germany" & @CRLF & _
"on 21 May 429.29 "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")