# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"site.*?\D\K(\d+\.\d{2})"
test_str = ("Debit card payment to site.com\n"
"Germany\n"
"on 01 May 1.30\n"
"Debit card payment to site Germany\n"
"on 01 May 4.63\n"
" Debit card payment to site.Com\n"
"Germany\n"
"on 01 May 3.30\n"
"Debit card payment to Paypal *Xiao\n"
"Ref:- 23948 0000000000 32.98\n"
"Debit card payment to site.Com\n"
"Germany\n"
"on 20 May 17.49\n"
"Debit card refund from site.Com\n"
"Germany\n"
"on 21 May 429.29 ")
matches = re.finditer(regex, test_str, re.IGNORECASE | re.DOTALL)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.