package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\d*).html`)
var str = `http://www.lacentrale.fr/auto-occasion-annonce-22885696.html
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}