re = /(\d*).html/
str = 'http://www.lacentrale.fr/auto-occasion-annonce-22885696.html
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end