#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "^|\W"
Local $sString = " Hi there."
Local $sSubst = "_"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)