package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^|\W`)
var str = ` Hi there.`
var substitution = "_"
fmt.Println(re.ReplaceAllString(str, substitution))
}