package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`today-temp[^>]+>([^<]+)<`)
var str = `<p class="today-temp">+10°C</p>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}