$re = '/today-temp[^>]+>([^<]+)</';
$str = '<p class="today-temp">+10°C</p>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);