package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(.+)_i\d+`)
var str = `prod-analitic_i1286
r1-prod-orders_i1365`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}