$re = '/(.+)_i\d+/m';
$str = 'prod-analitic_i1286
r1-prod-orders_i1365';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);