const regex = /(?(DEFINE)
(?<EXPR>
(?&EA) (?&EB)
)
(?<EA>
\( (?&EXPR) \) |
(?&ANY) |
(?&PREFIX) (?&EXPR)
)
(?<EB> # EXPR beta
(?&INFIX) (?&EXPR) |
(?&POSTFIX) |
)
# Operators
(?<INFIX>[+*\/-^])
(?<PREFIX>[+-])
(?<POSTFIX>)
# Literals
(?<ANY>
(?&INT)|(?&STRING)|(?&BOOL)|
(?&PROP)|(?&FUNC)
)
(?<FUNC>
=>\s*\(
((?&EXPR)(,\s*(?&EXPR))*)?
\)\s*
({(?&EXPR)}|(?&EXPR))
)
(?<PROP>
(?<PALPHA>
([A-Za-z$_][\w$]*)(\(
((?&EXPR)(,\s*(?&EXPR))*)?
\))?
)
(\.(?&PALPHA))*
)
(?<BOOL>true|false)
(?<STRING>
(["'])([^"\\]|\\.)*?\g{-2}
)
(?<INT>\d+)
)
^(?&EXPR)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?(DEFINE)
(?<EXPR>
(?&EA) (?&EB)
)
(?<EA>
\\( (?&EXPR) \\) |
(?&ANY) |
(?&PREFIX) (?&EXPR)
)
(?<EB> # EXPR beta
(?&INFIX) (?&EXPR) |
(?&POSTFIX) |
)
# Operators
(?<INFIX>[+*\\\/-^])
(?<PREFIX>[+-])
(?<POSTFIX>)
# Literals
(?<ANY>
(?&INT)|(?&STRING)|(?&BOOL)|
(?&PROP)|(?&FUNC)
)
(?<FUNC>
=>\\s*\\(
((?&EXPR)(,\\s*(?&EXPR))*)?
\\)\\s*
({(?&EXPR)}|(?&EXPR))
)
(?<PROP>
(?<PALPHA>
([A-Za-z$_][\\w$]*)(\\(
((?&EXPR)(,\\s*(?&EXPR))*)?
\\))?
)
(\\.(?&PALPHA))*
)
(?<BOOL>true|false)
(?<STRING>
(["\'])([^"\\\\]|\\\\.)*?\\g{-2}
)
(?<INT>\\d+)
)
^(?&EXPR)$', 'gm')
const str = `2+2*(3^5)
"halo"+"howjuicavocad"
foo.bar(baz).hello
=> (arg) arg+2`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}