$re = '/(?(DEFINE)
(?<EXPR>
(?&EA) (?&EB)
)
(?<EA>
\( (?&EXPR) \) |
(?&ANY) |
(?&PREFIX) (?&EXPR)
)
(?<EB> # EXPR beta
(?&INFIX) (?&EXPR) |
(?&POSTFIX) |
)
# Operators
(?<INFIX>[+*\/-^])
(?<PREFIX>[+-])
(?<POSTFIX>)
# Literals
(?<ANY>
(?&INT)|(?&STRING)|(?&BOOL)|
(?&PROP)|(?&FUNC)
)
(?<FUNC>
=>\s*\(
((?&EXPR)(,\s*(?&EXPR))*)?
\)\s*
({(?&EXPR)}|(?&EXPR))
)
(?<PROP>
(?<PALPHA>
([A-Za-z$_][\w$]*)(\(
((?&EXPR)(,\s*(?&EXPR))*)?
\))?
)
(\.(?&PALPHA))*
)
(?<BOOL>true|false)
(?<STRING>
(["\'])([^"\\\\]|\\\\.)*?\g{-2}
)
(?<INT>\d+)
)
^(?&EXPR)$/xm';
$str = '2+2*(3^5)
"halo"+"howjuicavocad"
foo.bar(baz).hello
=> (arg) arg+2';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);