use strict;
my $str = '
$pixo_blog[\'post_classes\'] = \'\';
$pixo_blog[\'layout\'] = zbx_helper::get_mb_or_option(\'blog-layout\', \'classic\');
$pixo_blog[\'sidebar\'] = zbx_settings::get_mb_or_option(\'sidebar\');
$pixo_blog[\'sidebar\'] = zorbix_settings::get_mb_or_option(\'sidebar\');
';
my $regex = qr/(zbx|zorbix)_(?:(?!(blog|helper)).)*::/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}