$re = '/(zbx|zorbix)_(?:(?!(blog|helper)).)*::/mi';
$str = '
$pixo_blog[\'post_classes\'] = \'\';
$pixo_blog[\'layout\'] = zbx_helper::get_mb_or_option(\'blog-layout\', \'classic\');
$pixo_blog[\'sidebar\'] = zbx_settings::get_mb_or_option(\'sidebar\');
$pixo_blog[\'sidebar\'] = zorbix_settings::get_mb_or_option(\'sidebar\');
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);