$re = '/^(?!.*\bipsum\b).*\blorem\b/im';
$str = 'Lorem ipsum dolor sit amet, consectetur adipiscing elit.
Vivamus fermentum semper porta.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);