re = /^(?!.*\bipsum\b).*\blorem\b/im
str = 'Lorem ipsum dolor sit amet, consectetur adipiscing elit.
Vivamus fermentum semper porta.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end