$re = '/\s*[[(].*?[])]\s*\K|\G(?!\A)(?:(?!\s*[[(].*?[])]\s*).)+/m';
$str = '(garbage info) filename (other garbage).extension or [garbage info] filename [other garbage].extension';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);