re = /\s*[[(].*?[])]\s*\K|\G(?!\A)(?:(?!\s*[[(].*?[])]\s*).)+/m
str = '(garbage info) filename (other garbage).extension or [garbage info] filename [other garbage].extension'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end