package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(-?\d{2}\.?\d{6})`)
var str = `-15.84220815.842208999999999... -48.023084`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}