$re = '/(-?\d{2}\.?\d{6})/';
$str = '-15.84220815.842208999999999... -48.023084';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);