using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(-\w+)(?:=|\s)?(""[^""]*""|\S+)?";
string input = @"-arg1 -arg2 -arg3=500 -arg4=-250,200,50.0 -arg5 ""Hello World"" -arg6 ""[I don't know whats going on /here/]"" -arg7=""this works too""";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}